tcpMDT
Revisar Perfiles Transversales - MDT26
Revisar Perfiles
Comando para ejecutar en el CAD | |
|---|---|
Menú vertical | MDT26 > Transversales > Revisar Perfiles |
Menú tipo cinta | MDT26 > Transversales > Edición > Revisar |
Línea de comandos |
Este comando permite editar perfiles transversales del terreno (ficheros tra), ficheros transversales de túnel (tri) así como trabajar con ficheros de transversales de puntos (trs) de los que nos podremos valer para extraer perfiles transversales a partir de dichos puntos y hacer un ajuste fino mediante las herramientas que nos provee la aplicación.
Una vez ejecutemos la aplicación veremos algo similar a esto:

A lo largo del documento detallaremos cada una de las partes, como visión general podemos distinguir varias secciones en la interfaz de la aplicación:
• Barra de título: En la parte superior, la barra con fondo naranja. Aparece el título de la aplicación en la parte izquierda. A la derecha encontramos algunas opciones: Ajustes, Ayuda y Acerca de nosotros. Más a la derecha tenemos los controles típicos de una ventana de Windows: minimizar, restaurar/maximizar y cerrar.
• Barra de herramientas: Justo debajo de la barra de título. Nos permite controlar el estado del visor y acceder a las diferentes herramientas de edición.
• Panel de perfiles transversales: Bajo la barra de herramientas, a la izquierda podemos ver un panel con la información del perfil transversal activo. Es posible editar múltiples transversales simultáneamente, en cuyo caso este panel nos mostrará siempre la información del que esté activo en cada momento
• Visor CAD: La aplicación provee de un visor CAD en el que se representarán los perfiles como polilíneas, también se podrán dibujar polilíneas arbitrarias y realizar medidas. En cada perfil, se dibuja una línea blanca en su PK 0. El PK actual siempre aparece centrado en la parte superior del visor.
• Menú de navegación: Justo debajo del visor CAD aparece el menú de navegación que nos permitirá desplazarnos por los diferentes PK de los perfiles transversales.
• Barra de estado: En la parte inferior de la ventana, la barra con fondo naranja. Nos provee de información general como: las coordenadas del cursor en el dibujo y mensajes de información durante los comandos de edición.
Ajustes
En la esquina superior derecha de la ventana encontraremos un botón de Ajustes. Al hacer clic sobre él nos aparecerá el siguiente diálogo:

General
• Tema: Define el aspecto visual de la aplicación. Por defecto, viene establecido como BaseDark por lo que la aplicación tendrá fondos oscuros y textos claros. El valor alternativo sería BaseLight que invertirá dicho esquema de color: fondos claros y textos oscuros.
• Color: Define la paleta de colores que emplea la aplicación. Por defecto, aparecerá en un color naranja (Orange). Se ofrece una variedad de colores posibles.
• Idioma: Permite seleccionar el idioma de la aplicación
• Puntos dinámicos: Cuando se activa está opción, las rejillas de datos de los perfiles solo muestran los datos de los vértices que estén actualmente visibles en el visor CAD. Si los datos de todos los vértices visibles no caben en la rejilla con el tamaño de ventana actual, se omitirán algunos de los vértices intermedios mostrando siempre los vértices extremos visibles. Esta opción puede resultar muy útil cuando se realiza un ajuste fino localizado, puesto que reduce la carga visual y nos permite enfocarnos en la zona de trabajo.
CAD
• Cursor: Establece el color del cursor del visor CAD. Este cursor solo es visible cuando hay un comando de edición activo.
• Puntos calientes: Establece el color de los puntos calientes de las entidades seleccionadas en el visor CAD.
• Referencia de entidades: Establece el color de las marcas de referencia de entidades sobre el visor CAD cuando estemos en una operación que emplee dichas referencias.
• Selección: Establece el color de los vértices seleccionados en una entidad del visor CAD.
• Escala de las marcas: Establece la escala de tamaño para las marcas del visor CAD: puntos calientes y referencia de entidades.
Una vez aceptado el diálogo, se establecerá la configuración y se recordará en futuras ejecuciones del programa.
Barra de Herramientas
En la barra de herramientas encontramos los controles que nos permitirán gestionar el visor CAD así como la edición de los perfiles:

Menú Archivo
Con los controles del menú archivo podemos incorporar ficheros ya existentes o guardar las modificaciones de los perfiles en edición:
Abrir: Solicita un fichero tra, tri o trs y lo incorpora al panel y al visor CAD. Es posible trabajar con múltiples ficheros tra simultáneamente pero solo puede haber un único fichero longitudinal de puntos (trs) cargado.
Guardar: Si hay un perfil activo, por defecto solicitará la ubicación para almacenar un nuevo fichero tra o tri con los datos actuales del perfil: si se ha modificado se guardarán las modificaciones, en otro caso será una copia exacta del original. Si se modifica la extensión del fichero de salida, o no hay un perfil activo al momento de hacer clic en este icono, se nos presentarán las siguientes opciones:
• Guardar como dxf: Guardará el dibujo actual del visor CAD en un fichero dxf. Esto incluye polilíneas que se hayan dibujado y las acotaciones realizadas.
• Guardar como jpg: Nos permitirá guardar una captura de lo que está visible actualmente en el visor CAD con georreferencia. Para configurar la captura se nos mostrará el siguiente diálogo:
Captura de pantalla Georreferenciada

Vista Actual
Área visible: Indica el tamaño de la pantalla en metros y pixeles.
Designar: Al hacer clic, entramos en un comando de zoom ventana con el que podemos establecer una región del dibujo en el visor para exportarla.
Configurar Imagen
Resolución: Nos permite establecer una resolución arbitraria, en pixeles, para la imagen capturada. Si la opción Mantener relación de aspecto está activada, la resolución siempre mantendrá la relación de aspecto actual del visor CAD. Variar la resolución afectara al tamaño de píxel.
Tamaño de píxel: Indica la escala de cada píxel en la imagen exportada. Por ejemplo, para una imagen que tiene un área visible de 100x100 metros y una resolución de 100x100 píxeles el tamaño de píxel será de 1x1 metros. Si la opción Mantener relación de aspecto está activada, el tamaño de píxel siempre será cuadrado lo que a su vez forzará que la resolución mantenga la relación de aspecto actual del visor CAD. Variar el tamaño de píxel afectará a la resolución.
Mantener relación de aspecto: Cuando está activada se fuerza que la resolución y el tamaño de píxel tengan la misma relación de aspecto que el visor CAD.
Generar Georreferencia: Si está activada, exporta un fichero de georreferencia jpw junto con la imagen jpg con lo que la imagen tendrá la información de tamaño de píxel y se podrá dibujar o medir sobre ella en cualquier software de CAD que permita trabajar con imágenes georreferenciadas. La imagen de salida siempre está ubicada con origen X=0,Y=0.
Menú CAD
Con los controles del menú CAD podemos gestionar el visor CAD:
Rejilla: Permite activar/desactivar la rejilla del visor
Color de fondo del visor: Nos permite establecer el color de fondo del visor CAD
Control de capas: Nos permite gestionar las capas del visor CAD. Si hacemos clic en el icono se mostrará el siguiente diálogo:

Cada capa tiene los siguientes controles:
Visibilidad: Establece si la capa está visible o no
Eliminar: Borra la capa del CAD. Esto no siempre es posible, hay capas especiales que no se pueden eliminar y cuyo ciclo de vida es gestionado por la aplicación. En este caso: la capa PNT donde se dibujan los puntos de los ficheros trs y las capas donde se dibujan los perfiles transversales de los ficheros tra o tri (una capa por fichero).
Nombre de capa: Nos permite modificar el nombre de la capa. Hay capas especiales que no se pueden renombrar. En este caso: la capa PNT donde se dibujan los puntos de los ficheros trs y las capas donde se dibujan los perfiles transversales de los ficheros tra o tri (una capa por fichero).
Grosor de línea/punto: Nos permite establecer el grosor de línea de la capa. Está limitado entre uno y diez.
Capa actual: Nos permite seleccionar la capa actual. Si seleccionamos una capa de un perfil (tendrá el mismo nombre que el fichero) se establecerá dicho perfil como activo. Además, se pueden mostrar/ocultar capas directamente desde esté control haciendo clic en el icono de visibilidad
Grosor de línea global: Establece el grosor de línea de todas las capas de forma simultánea.
Factor vertical: Permite establecer un factor de escala vertical para exagerar las cotas en el visor CAD. Se permiten factores de: x1, x2, x3, x4, x5 y x10
Menú de Previsualización de Cortes
Con estos controles podemos activar la representación de cortes anteriores y/o posteriores al actual en el visor CAD:
Podemos establecer hasta tres pasos como máximo en cada dirección. Las polilíneas se mostrarán siguiendo el siguiente esquema de colores:
• 1 paso atrás: rojo
• 2 pasos atrás: amarillo
• 3 pasos atrás: verde
• 1 paso adelante: azul
• 2 pasos adelante: magenta
• 3 pasos adelante: blanco
El primer perfil transversal incorporado siempre se muestra en color cian.
Menú Referencia de Entidades
Con estos controles podemos gestionar la referencia de entidades del visor CAD:
De izquierda a derecha:
• Referencia a punto: Si está activada se consideran entidades puntuales en la referencia de entidades. Útil para medir distancias entre puntos o para dibujar sobre puntos.
• Referencia a punto final: Si está activada se consideran los vértices de las entidades en la referencia de entidades.
• Referencia a punto medio: Si está activada considera los vértices centrales de los segmentos de entidades lineales en la referencia de entidades.
• Referencia a punto cercano: Si está activada considera el vértice más cercano al cursor de dibujo, ya sea final, centro de un segmento o un vértice cualquiera de un segmento de una entidad lineal.
• Activar/desactivar referencias: Establece si se debe considerar o no la referencia de entidades.
Menú Historia
Con los controles del menú historia podemos deshacer/rehacer los cambios realizados sobre los perfiles.:
De izquierda a derecha:
• Deshacer: Deshace la última modificación del perfil activo.
• Rehacer: Vuelve a aplicar la última modificación deshecha al perfil activo.
Estos controles solo se activarán cuando haya un perfil activo y este haya tenido alguna modificación. Cada perfil tiene su propio historial de modificaciones independiente, por lo que es posible que al poner como activo un perfil se activen ambos controles y con otro perfil no se active ninguno. Entendiéndose como perfil no el fichero en sí, sino los vértices de un PK concreto de un fichero de transversales.
Menú Edición
Con los controles de edición podemos iniciar diversos comandos de edición sobre entidades del visor CAD (tanto perfiles como polilíneas dibujadas):
Dibujar polilínea: Comienza el comando de dibujar polilínea en el CAD. Si pulsamos la tecla backspace, cuando estamos dibujando la polilínea, se borrará el último vértice introducido. Se puede terminar el dibujo con Intro o Escape.
Insertar vértice: Comienza el comando de insertar vértice. Como primer paso debemos designar una entidad lineal a la que insertar el vértice. En el caso de polilíneas dibujadas, se insertará el vértice en el segmento más cercano al cursor cuando se designó la entidad y se permitirá establecer las coordenadas exactas del mismo con el cursor. En caso de perfiles transversales de terreno, se insertará el vértice en las coordenadas del cursor, estableciéndose los vértices anteriores y posteriores según la proyección en X del nuevo vértice (dado que en un perfil de terreno el PK siempre es creciente y no puede haber dos cotas en un mismo PK). En el caso de perfiles de túnel se comportará como en el caso de las polilíneas de dibujo.
Eliminar vértice: Comienza el comando de eliminar vértice. Como primer paso debemos designar una entidad lineal a la que eliminar vértices. Tras esto, veremos que se muestran sus vértices como puntos calientes y si hacemos clic en alguno de ellos se eliminará.
Eliminar rango de vértices: Comienza el comando de eliminar un rango de vértices. Como primer paso debemos designar una entidad lineal a la que eliminar vértices. Tras esto, veremos que se muestran sus vértices como puntos calientes. Habrá que marcar dos vértices, el inicial y el final, se eliminarán ambos y los vértices intermedios.
Eliminar vértices por ventana: Comienza el comando de eliminar vértices por ventana. Como primer paso debemos designar una entidad lineal a la que eliminar vértices. Tras esto, veremos que se muestran sus vértices como puntos calientes. Habrá que marcar las dos esquinas de la ventana, todos los vértices que queden contenidos en la misma se eliminarán de la entidad.
Fusionar polilíneas: Comienza el comando de fusionar polilíneas. Como primer paso debemos seleccionar la polilínea que queremos modificar con la fusión. Tras esto, debemos designar la polilínea con la que la vamos a fusionar. Al seleccionar las dos polilíneas se fusionarán según dos criterios: si hay intersecciones entre ellas, entre la primera y la última intersección se eliminarán todos los vértices de la polilínea original y se insertarán los de la polilínea de fusión. En caso de no haber intersecciones, se buscan los vértices más cercanos a los extremos de la polilínea de fusión en la polilínea original y en dicho rango se realiza la fusión. La polilínea de fusión se elimina una vez que el comando termina.
Edición rápida: Es un atajo para primero dibujar polilínea y luego fusionar polilíneas. Si entramos en el modo de edición rápida, entraremos en el comando de dibujar polilínea, cuando confirmemos la polilínea entramos automáticamente en el comando de fusionar polilínea usando como polilínea de fusión la que acabamos de dibujar. Este comando no termina hasta que se termina explícitamente con la tecla intro o escape, o con las funciones análogas en el menú de contexto. Cambiar de PK no cancela este comando.
Descartar puntos por ventana: Cuando extraemos un perfil a partir de puntos de forma automática, se habilita este comando al tener activo dicho perfil. El comando nos permite designar una ventana y todos los puntos contenidos en la misma se descartarán del proceso de extracción del perfil, por lo que este se recalculará en el rango afectado por los puntos descartados y se readaptará la polilínea.
Menú Medición y Borrado
Con estos controles podemos establecer medidas en el dibujo, así como eliminarlas y borrar entidades del dibujo:
Medir: El comando medir nos pedirá designar dos puntos y nos dirá la distancia entre ellos. Se añadirá una línea con un texto con la medida al dibujo a una capa especial de medidas.

Medir (XY): Es idéntico al comando de medir salvo que este al terminar inserta en el dibujo dos líneas adicionales con texto, mostrando la distancia en X e Y entre los dos puntos designados.

Eliminar medidas: Borra del dibujo todas las mediciones.
Borrar entidades: Nos permite hacer una selección de entidades y eliminarlas del dibujo. Cuando entremos en este comando, al designar la entidad veremos que sus líneas se vuelven discontinuas, esto significa que está seleccionada para el borrado. Cuando estén seleccionadas todas las entidades pulsando intro, o usando la función análoga del menú de contexto, confirmamos el borrado. También se pueden borrar entidades seleccionándolas en el visor (haciendo clic sobre ellas) y pulsando la tecla suprimir. Hay entidades especiales que no se podrán eliminar, como las polilíneas que representan a los perfiles transversales.
Menú Zoom
Con estos controles podemos controlar el nivel de zoom del visor CAD:
Incrementar zoom: Aumenta el nivel de zoom actual
Reducir zoom: Reduce el nivel de zoom actual.
Zoom ventana: Se solicitará que se designen dos vértices para formar una ventana, la vista pasará a ser el contenido de dicha ventana haciendo el zoom necesario y centrando la vista en la misma.
Zoom extensión: Establece la vista de manera que todos los elementos que hay actualmente en el dibujo sean visibles.
Menú de Gestión de Puntos
Estos controles solo se muestran cuando hay un fichero de puntos (trs) activo:
Extraer perfil: Permite generar un fichero de perfiles transversales automáticamente a partir de los puntos. Dichos perfiles siempre parten del punto con mínimo desplazamiento en cada PK y avanza según los criterios definidos en el siguiente diálogo:
Extraer Perfil a partir de Puntos

• Opciones: El criterio que debe emplearse para obtener el siguiente vértice del perfil:
o Máximo: Coge el punto con máxima cota en el ancho de banda definido por las distancias mínima y máxima.
o Media: Coge la media de los puntos contenidos en el ancho de banda definido por las distancias mínima y máxima.
o Mínima: Coge el punto con mínima cota en el ancho de banda definido por las distancias mínima y máxima.
• Distancia mínima: Desde el vértice actual, a que distancia (diferencia de PK) del mismo debe estar, como mínimo, el siguiente punto a considerar.
• Distancia máxima: Desde el vértice actual, a que distancia (diferencia de PK) del mismo puede estar, como máximo, el siguiente punto a considerar.
• Nombre: El nombre del fichero tra resultante de la extracción.
Grosor de punto: Nos permite establecer el tamaño de los puntos en el visor CAD. Se puede establecer entre 1 y 10, ambos inclusive.
Borrar puntos: Elimina el fichero de transversales de puntos actual de la aplicación.
Panel de Perfiles Transversales
En la parte izquierda de la pantalla, se mostrarán los datos de los perfiles que están actualmente en edición. En caso de trabajar con múltiples perfiles simultáneamente, si en algún PK alguno de ellos no está definido y se establece como activo, se mostrará en el panel un mensaje advirtiendo de ello en lugar del listado de vértices.

Cerrar: Con este botón se cierra el perfil activo. Si este tuviera alguna modificación se nos preguntará si deseamos: guardar los cambios en el fichero original o en un nuevo fichero, descartar los cambios o cancelar el cierre.

Cuando se cierra la aplicación, se deben cerrar todos los perfiles. Se mostrará el siguiente diálogo para que se confirme si se desea guardar las modificaciones de dichos perfiles (modificando el fichero original), también se puede cancelar el cierre:

Insertar: Con este botón podemos agregar nuevos vértices al transversal, estableciendo PK, Cota y Código:

Listado de vértices:
Para cada vértice del perfil, tendremos en el listado una línea como esta:
Los elementos, de izquierda a derecha son:
• Distancia: La distancia del vértice al eje de corte. Podemos hacer doble clic sobre el mismo y escribir la nueva distancia del vértice. En el caso de un perfil de terreno, el listado se reordenará por distancia tras el cambio. Si trata de establecer dos vértices a la misma distancia, la aplicación mostrará un mensaje de error y no hará la modificación, puesto que un perfil transversal de terreno no soporta la definición de dos cotas diferentes para la misma distancia. En el caso de un perfil de túnel, no se aplican estas restricciones.
• Cota: La cota del vértice. Podemos hacer doble clic sobre la misma y escribir la nueva cota del vértice.
• Código: El código del vértice. Podemos hacer doble clic sobre el mismo y escribir el nuevo código del vértice.
•
Borrar: Elimina el vértice. También es posible eliminar el vértice si se selecciona la fila del listado y se pulsa la tecla suprimir.
Si se selecciona una fila del listado, el vértice correspondiente se resaltará en el visor CAD.
Si activamos en los Ajustes la opción Puntos dinámicos en el listado solo aparecerán los puntos que sean visibles en el visor CAD en cada momento.
Eliminar un pk:
En la parte inferior derecha del panel podemos encontrar el botón:
Si hacemos clic sobre él, se eliminará el PK actual del perfil activo. La aplicación solicitará que confirme el borrado, ya que esta operación no se puede deshacer.
Perfiles en edición:
En la parte inferior del panel podemos ver los nombres de los perfiles que están actualmente en edición:
El resaltado es el perfil activo. Podemos establecer un perfil como activo: haciendo clic en su nombre en el panel, haciendo clic en la polilínea del perfil en el visor CAD, estableciendo como capa actual la capa que tiene el nombre del perfil.
Barra de Navegación
Con estos controles podemos navegar entre los distintos PK donde están definidos los perfiles. También podemos ir al PK anterior o siguiente con las flechas de dirección izquierda y derecha respectivamente.

Ir al primer PK: Salta al primer PK de los perfiles transversales en edición.
Ir al PK anterior: Salta al PK anterior al actual
PK actual: Muestra el PK actual
Selector de PK: La zona naranja representa la longitud recorrida en los perfiles. La zona gris representa la longitud que queda por recorrer. El rectángulo blanco es el cursor que indica el PK actual. Podemos hacer clic un punto de esta barra y saltaremos al PK que le corresponda. También es posible arrastrar el cursor y moverse por los diferentes PK.
Ir al PK siguiente: Salta al PK siguiente al actual
Ir al PK final: Salta al PK final de los perfiles transversales en edición
Visor CAD
Desde el visor CAD podemos editar gráficamente los perfiles transversales, así como dibujar y editar polilíneas:

Al hacer clic sobre una polilínea, esta pasará a selección y, si representa a un perfil transversal, este se establecerá como activo. Al seleccionarse la entidad, veremos sus vértices como puntos calientes:

Una vez en selección, si ponemos el cursor sobre uno de los vértices este se resaltará, tanto en el visor como en el panel (en el caso de perfiles transversales), y se mostrará el menú de contexto radial.
Menú de Contexto Radial
Cuando se resalta un vértice de una entidad seleccionada en el visor CAD, aparece este menú indicando las posibles operaciones sobre el vértice:

Editar: Nos permite reubicar el vértice gráficamente con el cursor. En el caso de perfiles transversales de terreno, la edición nos obligará a mantener la distancia del vértice entre el anterior y el posterior en todo momento, en otro caso no nos dejará confirmar la edición.
Insertar: Inserta un nuevo vértice. En el caso de perfiles transversales de terreno, la inserción se realiza de forma libre. Conforme movamos el cursor, veremos el resultado de confirmar la inserción en la ubicación del mismo. Al hacer clic se inserta el vértice. Podemos repetir la operación tantas veces como deseemos, el comando termina cuando se pulse "intro" o "escape", o las funciones análogas en el menú de contexto. En el caso de polilíneas dibujadas o perfiles transversales de túnel, se insertará el nuevo vértice entre el vértice resaltado y el posterior, pudiendo luego reubicarlo con el cursor.
Borrar: Elimina el vértice. También es posible borrarlo, una vez que esté resaltado, pulsando la tecla suprimir.
Más opciones: Mostrará el menú de contexto mostrando todas las opciones de edición posibles sobre la entidad.
Menú de Contexto
En cualquier momento que hagamos clic derecho sobre el visor CAD, aparecerá el menú de contexto de la aplicación:

Las operaciones de edición solo aparecerán cuando hagamos clic derecho sobre una entidad. Dichas operaciones de edición son las mismas del Menú Edición de la barra de herramientas, si las usamos desde este menú evitamos tener que designar la entidad al comenzar el comando, puesto que ya se conoce la entidad sobre la que se desea actuar.
De la misma manera, en los submenús de Referencia de Entidades y Zoom encontramos los comandos de los menús de mismo nombre de la barra de herramientas:


Si la aplicación se encuentra en un comando y se abre el menú contextual, haciendo clic derecho en el visor CAD, se nos darán opciones adicionales para terminar el comando, mediante un intro o un escape:
