tcpMDT
[PRO] Revisar Rasante - MDT26
Revisar Rasante
Comando para ejecutar en el CAD | |
|---|---|
Menú vertical | MDT26 > Rasantes > Revisar Rasante |
Menú tipo cinta | MDT26 > Rasantes > Edición > Revisar |
Línea de comandos |
Esta aplicación nos permite visualizar y editar una rasante (ficheros ras) así como visualizar el perfil longitudinal del terreno (fichero lon) como referencia y modificar la rasante mediante las herramientas que nos provee la aplicación.
Una vez ejecutemos la aplicación veremos algo similar a esto:
![[PRO] Revisar Rasante - MDT26 (3)](/media/157909160/image31.webp)
A lo largo del documento detallaremos cada una de las partes, como visión general podemos distinguir varias secciones en la interfaz de la aplicación:
Barra de título: En la parte superior, la barra con fondo naranja. Aparece el título de la aplicación en la parte izquierda. A la derecha encontramos algunas opciones: Ajustes, Ayuda y Acerca de nosotros. Más a la derecha tenemos los controles típicos de una ventana de Windows: minimizar, restaurar/maximizar y cerrar.
Barra de herramientas: Justo debajo de la barra de título. Nos permite controlar el estado del visor y acceder a las diferentes herramientas de edición.
Visor CAD: La aplicación provee de un visor CAD en el que se representarán la rasante previa y definitiva como polilíneas, también se podrán realizar medidas que quedarán como acotaciones en el dibujo.
Panel de rasante: Bajo el visor CAD podemos ver un panel con la información de la rasante activa.
Barra de estado: En la parte inferior de la ventana, la barra con fondo naranja. Nos provee de información general como: las coordenadas del cursor en el dibujo, la cota rasante y (en caso de estar mostrando el longitudinal del terreno) la cota de terreno y la cota roja. También se mostrarán mensajes de información durante los comandos de edición.
Ajustes
En la esquina superior derecha de la ventana encontraremos un botón de Ajustes. Al hacer clic sobre él nos aparecerá el siguiente diálogo:
![[PRO] Revisar Rasante - MDT26 (4)](/media/157909160/image32.png)
General
Tema: Define el aspecto visual de la aplicación. Por defecto, viene establecido como BaseDark por lo que la aplicación tendrá fondos oscuros y textos claros. El valor alternativo sería BaseLight que invertirá dicho esquema de color: fondos claros y textos oscuros.
Color: Define la paleta de colores que emplea la aplicación. Por defecto, aparecerá en un color naranja (Orange). Se ofrece una variedad de colores posibles.
Idioma: Permite seleccionar el idioma de la aplicación
CAD
Cursor: Establece el color del cursor del visor CAD. Este cursor solo es visible cuando hay un comando de edición activo.
Puntos calientes: Establece el color de los puntos calientes de las entidades seleccionadas en el visor CAD.
Referencia de entidades: Establece el color de las marcas de referencia de entidades sobre el visor CAD cuando estemos en una operación que emplee dichas referencias.
Selección: Establece el color de los vértices seleccionados en una entidad del visor CAD.
Escala de las marcas: Establece la escala de tamaño para las marcas del visor CAD: puntos calientes y referencia de entidades.
Editor
Colores de capa por defecto: Nos permite establecer los colores con los que se crean las capas en el visor CAD.
PRV: Color de la rasante previa, por defecto verde oscuro.
DEF: Color de la rasante definitiva, por defecto roja.
TXT: Color de los textos, por defecto violeta.
LON: Color del longitudinal, por defecto verde claro.
Barra de Herramientas
En la barra de herramientas encontramos los controles que nos permitirán gestionar el visor CAD así como la edición de la rasante:
![[PRO] Revisar Rasante - MDT26 (5)](/media/157909160/image33.webp)
Menú Archivo
Con los controles del menú archivo podemos crear una rasante de cero, incorporar ficheros ya existentes o guardar las modificaciones de la rasante en edición:
Nuevo: Crear una nueva rasante desde 0. Solicitará la ruta del nuevo fichero de rasante y agregará al panel la rasante vacía.
Abrir: Solicita un fichero ras, lon o LandXml y lo incorpora al panel y al visor CAD. En caso de importar la rasante de un LandXml que contenga múltiples rasantes se mostrará el siguiente diálogo para seleccionar la rasante a importar:
![[PRO] Revisar Rasante - MDT26 (9)](/media/157909160/image37.png)
Una vez aceptado, nos solicitará la ruta donde almacenar el ras importado y lo establecerá como el fichero activo en la aplicación
Guardar: Si hay una rasante activa, por defecto solicitará la ubicación para almacenar un nuevo fichero ras con los datos actuales de la rasante: si se ha modificado se guardarán las modificaciones, en otro caso será una copia exacta del original. Si se modifica la extensión del fichero de salida, o no hay una rasante activa al momento de hacer clic en este icono, se nos presentarán las siguientes opciones:
Guardar como dxf: Guardará el dibujo actual del visor CAD en un fichero dxf. Esto incluye polilíneas que se hayan dibujado y las acotaciones realizadas.
Guardar como jpg: Nos permitirá guardar una captura de lo que está visible actualmente en el visor CAD con georreferencia. Para configurar la captura se nos mostrará el siguiente diálogo:
Captura de pantalla Georreferenciada
![[PRO] Revisar Rasante - MDT26 (11)](/media/157909160/image39.webp)
Vista Actual
Área visible: Indica el tamaño de la pantalla en metros y pixeles.
Designar: Al hacer clic, entramos en un comando de zoom ventana con el que podemos establecer una región del dibujo en el visor para exportarla.
Configurar Imagen
Resolución: Nos permite establecer una resolución arbitraria, en pixeles, para la imagen capturada. Si la opción Mantener relación de aspecto está activada, la resolución siempre mantendrá la relación de aspecto actual del visor CAD. Variar la resolución afectara al tamaño de píxel.
Tamaño de píxel: Indica la escala de cada píxel en la imagen exportada. Por ejemplo, para una imagen que tiene un área visible de 100x100 metros y una resolución de 100x100 píxeles el tamaño de píxel será de 1x1 metros. Si la opción Mantener relación de aspecto está activada, el tamaño de píxel siempre será cuadrado lo que a su vez forzará que la resolución mantenga la relación de aspecto actual del visor CAD. Variar el tamaño de píxel afectará a la resolución.
Mantener relación de aspecto: Cuando está activada se fuerza que la resolución y el tamaño de píxel tengan la misma relación de aspecto que el visor CAD.
Generar Georreferencia: Si está activada, exporta un fichero de georreferencia jpw junto con la imagen jpg con lo que la imagen tendrá la información de tamaño de píxel y se podrá dibujar o medir sobre ella en cualquier software de CAD que permita trabajar con imágenes georreferenciadas. La imagen de salida siempre está ubicada con origen X=0,Y=0
Menú CAD
Con los controles del menú CAD podemos gestionar el visor CAD:
Rejilla: Permite activar/desactivar la rejilla del visor
Color de fondo del visor: Nos permite establecer el color de fondo del visor CAD
Control de capas: Nos permite gestionar las capas del visor CAD. Si hacemos clic en el icono se mostrará el siguiente diálogo:
![[PRO] Revisar Rasante - MDT26 (16)](/media/157909160/image44.webp)
Cada capa tiene los siguientes controles:
Visibilidad: Establece si la capa está visible o no
Eliminar: Borra la capa del CAD. Esto no siempre es posible, hay capas especiales que no se pueden eliminar y cuyo ciclo de vida es gestionado por la aplicación.
Nombre de capa: Nos permite modificar el nombre de la capa. Hay capas especiales que no se pueden renombrar.
Grosor de línea/punto: Nos permite establecer el grosor de línea de la capa. Está limitado entre uno y diez.
Capa actual: Nos permite seleccionar la capa actual. Además, se pueden mostrar/ocultar capas directamente desde esté control haciendo clic en el icono de visibilidad
Grosor de línea global: Establece el grosor de línea de todas las capas de forma simultánea.
Factor vertical: Permite establecer un factor de escala vertical para exagerar las cotas en el visor CAD. Se permiten factores de: x1, x2, x3, x4, x5 y x10
Menú Referencia de Entidades
Con estos controles podemos gestionar la referencia de entidades del visor CAD:
De izquierda a derecha:
Referencia a punto: Si está activada se consideran entidades puntuales en la referencia de entidades. Útil para medir distancias entre puntos o para dibujar sobre puntos.
Referencia a punto final: Si está activada se consideran los vértices de las entidades en la referencia de entidades.
Referencia a punto medio: Si está activada considera los vértices centrales de los segmentos de entidades lineales en la referencia de entidades.
Referencia a punto cercano: Si está activada considera el vértice más cercano al cursor de dibujo, ya sea final, centro de un segmento o un vértice cualquiera de un segmento de una entidad lineal.
Activar/desactivar referencias: Establece si se debe considerar o no la referencia de entidades.
Menú Historia
Con los controles del menú historia podemos deshacer/rehacer los cambios realizados sobre la rasante.:
De izquierda a derecha:
Deshacer: Deshace la última modificación de la rasante.
Rehacer: Vuelve a aplicar la última modificación deshecha a la rasante.
Estos controles solo se activarán cuando haya una rasante activa y esta haya tenido alguna modificación.
Menú Edición
Con los controles de edición podemos iniciar diversos comandos de edición sobre entidades del visor CAD (tanto perfiles como polilíneas dibujadas):
Insertar vértice: Comienza el comando de insertar vértice. Se nos solicitará designar una entidad, para editar la rasante hemos de seleccionar la polilínea que representa a la rasante previa. Se insertará el vértice en las coordenadas del cursor, estableciéndose los vértices anteriores y posteriores según la proyección en X del nuevo vértice (dado que en una rasante el PK siempre es creciente y no puede haber dos cotas en un mismo PK). El comando nos permitirá insertar vértices hasta que explícitamente lo acabemos pulsando "intro" o "escape", o con las funciones análogas del menú de contexto.
Eliminar vértice: Comienza el comando de eliminar vértice Se nos solicitará designar una entidad, para editar la rasante hemos de seleccionar la polilínea que representa a la rasante previa. Tras esto, veremos que se muestran sus vértices como puntos calientes y si hacemos clic en alguno de ellos se eliminará.
Eliminar rango de vértices: Comienza el comando de eliminar un rango de vértices Se nos solicitará designar una entidad, para editar la rasante hemos de seleccionar la polilínea que representa a la rasante previa. Tras esto, veremos que se muestran sus vértices como puntos calientes. Habrá que marcar dos vértices, el inicial y el final, se eliminarán ambos y los vértices intermedios.
Eliminar vértices por ventana: Comienza el comando de eliminar vértices por ventana. Se nos solicitará designar una entidad, para editar la rasante hemos de seleccionar la polilínea que representa a la rasante previa. Tras esto, veremos que se muestran sus vértices como puntos calientes. Habrá que marcar las dos esquinas de la ventana, todos los vértices que queden contenidos en la misma se eliminarán de la entidad.
Fusionar polilíneas: Comienza el comando de fusionar polilíneas. Como primer paso debemos seleccionar la polilínea que queremos modificar con la fusión. Tras esto, debemos designar la polilínea con la que la vamos a fusionar. Al seleccionar las dos polilíneas se fusionarán según dos criterios: si hay intersecciones entre ellas, entre la primera y la última intersección se eliminarán todos los vértices de la polilínea original y se insertarán los de la polilínea de fusión. En caso de no haber intersecciones, se buscan los vértices más cercanos a los extremos de la polilínea de fusión en la polilínea original y en dicho rango se realiza la fusión. La polilínea de fusión se elimina una vez que el comando termina.
Menú de Rasante
Los controles de este menú controlan aspectos que afectan en exclusiva a la rasante:
De izquierda a derecha:
Restricciones de cursor: Cuando se modifica la rasante previa de forma gráfica es posible restringir el cursor para tener un mayor control sobre la edición. Los posibles modos son:
Libre: No hay restricciones de movimiento
Fijar cota: Solo se permite desplazar los vértices horizontalmente.
Fijar PK: Solo se permite desplazar los vértices verticalmente
Fijar a Tangente Anterior: El movimiento estará limitado a la dirección definida por la tangente del vértice actual con el anterior.
Fijar a Tangente Posterior: El movimiento estará limitado a la dirección definida por la tangente del vértice actual con el posterior.
Marcar Punto de Paso: Permite marcar un punto gráficamente y que se reajuste la rasante para que la rasante definitiva pase por las coordenadas marcadas. Esto no siempre es posible, en caso de que se produjera un solape con el cambio la rasante no se modificará y nos aparecerá un mensaje de error alertándonos.
Menú Medición y Borrado
Con estos controles podemos establecer medidas en el dibujo, así como eliminarlas y borrar entidades del dibujo:
Medir: El comando medir nos pedirá designar dos puntos y nos dirá la distancia entre ellos. Se añadirá una línea con un texto con la medida al dibujo a una capa especial de medidas.
![[PRO] Revisar Rasante - MDT26 (37)](/media/157909160/image64.webp)
Medir (XY): Es idéntico al comando de medir salvo que este al terminar inserta en el dibujo dos líneas adicionales con texto, mostrando la distancia en X e Y entre los dos puntos designados.
![[PRO] Revisar Rasante - MDT26 (39)](/media/157909160/image66.webp)
Eliminar medidas: Borra del dibujo todas las mediciones.
Borrar entidades: Nos permite hacer una selección de entidades y eliminarlas del dibujo. Cuando entremos en este comando, al designar la entidad veremos que sus líneas se vuelven discontinuas, esto significa que está seleccionada para el borrado. Cuando estén seleccionadas todas las entidades pulsando intro, o usando la función análoga del menú de contexto, confirmamos el borrado. También se pueden borrar entidades seleccionándolas en el visor (haciendo clic sobre ellas) y pulsando la tecla suprimir. Hay entidades especiales que no se podrán eliminar.
Menú Zoom
Con estos controles podemos controlar el nivel de zoom del visor CAD:
Incrementar zoom: Aumenta el nivel de zoom actual
Reducir zoom: Reduce el nivel de zoom actual.
Zoom ventana: Se solicitará que se designen dos vértices para formar una ventana, la vista pasará a ser el contenido de dicha ventana haciendo el zoom necesario y centrando la vista en la misma.
Zoom extensión: Establece la vista de manera que todos los elementos que hay actualmente en el dibujo sean visibles.
Panel de Rasante
Bajo el visor CAD veremos un panel con la información de la rasante en edición.
![[PRO] Revisar Rasante - MDT26 (47)](/media/157909160/image74.webp)
Insertar: Mostrará el diálogo de Editar Nodo Rasante para que podamos introducir el PK y Cota del nuevo nodo. En todo momento veremos, como una línea amarilla discontinua, como quedará la rasante definitiva con la modificación. En caso de que la inserción produzca un solape nos advertirá y no se permitirá aceptar el diálogo.
Listado de nodos:
Para cada nodo de la rasante se muestra en el listado la siguiente información, de izquierda a derecha:
PK: El PK del nodo. Se podrá editar haciendo doble clic, solo se podrá confirmar si en el nuevo PK el nodo no provoca un solape.
Cota: La cota del nodo. Se podrá editar haciendo doble clic, solo se podrá confirmar si con la nueva cota el nodo no provoca un solape.
Kv: Acuerdo vertical del nodo. Se podrá editar haciendo doble clic, solo se podrá confirmar si con el nuevo Kv el nodo no provoca un solape.
Tangente: Longitud de la tangente del nodo. Se podrá editar haciendo doble clic, solo se podrá confirmar si con la nueva tangente el nodo no provoca un solape.
Flecha: Longitud de la flecha del nodo. Se podrá editar haciendo doble clic, solo se podrá confirmar si con la nueva flecha el nodo no provoca un solape.
Pendiente: El valor de pendiente del nodo. Es la pendiente entre el nodo y el siguiente. La dirección de la pendiente viene determinada por el signo. La pendiente positiva se mostrará con un texto verde, la negativa con un texto rojo.
Eliminar: Elimina el nodo de la rasante.
Herramientas de rasante:
En la parte inferior derecha del panel podemos encontrar herramientas específicas de edición de rasante:
Desplazar PKs: Nos permite establecer un nuevo PK inicial para la rasante, modificando en consecuencia los PK de todos los vértices.
![[PRO] Revisar Rasante - MDT26 (52)](/media/157909160/image78.png)
Desplazar cotas: Nos permite establecer un desplazamiento de cota que será aplicado a todos los vértices de la rasante.
![[PRO] Revisar Rasante - MDT26 (54)](/media/157909160/image80.webp)
Invertir: Invierte el sentido de la rasante
Editar Nodo Rasante
Este diálogo se mostrará al insertar un nuevo vértice en la rasante y en algunas operaciones de edición, como editar el acuerdo desde el Menú de Contexto Radial.
![[PRO] Revisar Rasante - MDT26 (56)](/media/157909160/image82.webp)
PK: Nos permite definir el PK del nodo. En el caso de haber insertado el nodo gráficamente o usar el comando de editar acuerdo estará bloqueado.
Cota: Nos permite definir la cota del nodo. En el caso de haber insertado el nodo gráficamente o usar el comando de editar acuerdo estará bloqueada.
Kv: Nos permite definir el acuerdo vertical del nodo. En caso de estar insertando un nodo desde el Panel de Rasante estará bloqueado.
Tangente: Nos permite definir la tangente del nodo. En caso de estar insertando un nodo desde el Panel de Rasante estará bloqueada.
Flecha: Nos permite definir la flecha del nodo. En caso de estar insertando un nodo desde el Panel de Rasante estará bloqueada.
En todo momento veremos, como una línea amarilla discontinua, el resultado de aplicar las modificaciones a la rasante. Si los parámetros introducidos provocaran un solape el diálogo mostrará un mensaje de alerta y bloqueará el botón de aceptar.
Visor CAD
Desde el visor CAD podemos editar gráficamente la rasante:
![[PRO] Revisar Rasante - MDT26 (57)](/media/157909160/image83.webp)
Al hacer clic sobre la rasante previa, esta pasará a selección. Al seleccionarse la entidad, veremos sus vértices como puntos calientes:
![[PRO] Revisar Rasante - MDT26 (58)](/media/157909160/image84.webp)
Una vez en selección, si ponemos el cursor sobre uno de los vértices este se resaltará, tanto en el visor como en el panel de rasante, y se mostrará el menú de contexto radial.
Menú de Contexto Radial
Cuando se resalta un vértice de una entidad seleccionada en el visor CAD, aparece este menú indicando las posibles operaciones sobre el vértice:
![[PRO] Revisar Rasante - MDT26 (59)](/media/157909160/image85.webp)
Editar: Nos permite reubicar el vértice gráficamente con el cursor. En el caso de tener activas restricciones de cursor, el movimiento del vértice estará limitado a la dirección que defina dicha restricción.
Editar acuerdo: Muestra el diálogo de Editar Nodo Rasante con el que podremos editar Kv, tangente y flecha del nodo.
Insertar: Inserta un nuevo vértice. En el caso de rasantes, la inserción se realiza de forma libre. Conforme movamos el cursor, veremos el resultado de confirmar la inserción en la ubicación del mismo. Al hacer clic se inserta el vértice, siempre que no se produzca un solape, y se muestra el diálogo de Editar Nodo Rasante para definir los parámetros del acuerdo. Si aceptamos el diálogo de edición el vértice queda insertado. Podemos repetir la operación tantas veces como deseemos, el comando termina cuando se pulse "intro" o "escape", o las funciones análogas en el menú de contexto.
Borrar: Elimina el vértice. También es posible borrarlo, una vez que esté resaltado, pulsando la tecla suprimir.
Más opciones: Mostrará el menú de contexto mostrando todas las opciones de edición posibles sobre la entidad.
Menú de Contexto
En cualquier momento que hagamos clic derecho sobre el visor CAD, aparecerá el menú de contexto de la aplicación:
![[PRO] Revisar Rasante - MDT26 (65)](/media/157909160/image91.png)
El submenú de restricciones de cursor y la herramienta Marcar Punto de Paso son idénticas a las vistas en la Barra de Herramientas en el Menú de Rasante.
Las operaciones de edición solo aparecerán cuando haya una rasante activa. Dichas operaciones de edición son las mismas del Menú Edición de la barra de herramientas.
![[PRO] Revisar Rasante - MDT26 (66)](/media/157909160/image92.png)
De la misma manera, en los submenús de Referencia de Entidades y Zoom encontramos los comandos de los menús de mismo nombre de la barra de herramientas:
![[PRO] Revisar Rasante - MDT26 (67)](/media/157909160/image93.png)
![[PRO] Revisar Rasante - MDT26 (68)](/media/157909160/image94.png)
Si la aplicación se encuentra en un comando y se abre el menú contextual, haciendo clic derecho en el visor CAD, se nos darán opciones adicionales para terminar el comando, mediante un intro o un escape:
![[PRO] Revisar Rasante - MDT26 (69)](/media/157909160/image95.png)