tcpMDT
[PRO] Revisar Peraltes - MDT25
13.18 [PRO] Revisar Peraltes
Esta aplicación nos permite visualizar y editar un fichero de peraltes (ficheros per) así como visualizar el diagrama de curvatura de un eje (ficheros EJE).
Una vez ejecutemos la aplicación veremos algo similar a esto:
![[PRO] Revisar Peraltes - MDT25 (2)](/media/61702429/image43.webp)
A lo largo del documento detallaremos cada una de las partes, como visión general podemos distinguir varias secciones en la interfaz de la aplicación:
Barra de título: En la parte superior, la barra con fondo naranja. Aparece el título de la aplicación en la parte izquierda. A la derecha encontramos algunas opciones: Ajustes, Ayuda y Acerca de nosotros. Más a la derecha tenemos los controles típicos de una ventana de Windows: minimizar, restaurar/maximizar y cerrar.
Barra de herramientas: Justo debajo de la barra de título. Nos permite controlar el estado del visor y acceder a las diferentes herramientas de edición.
Panel de peraltes: Bajo la barra de herramientas, a la izquierda podemos ver un panel con la información de los peraltes.
Visor CAD: La aplicación provee de un visor CAD en el que se representarán los peraltes como polilíneas, también se podrán realizar medidas.
Barra de estado: En la parte inferior de la ventana, la barra con fondo naranja. Nos provee de información general como: las coordenadas del cursor en el dibujo y mensajes de información durante los comandos de edición.
Ajustes
En la esquina superior derecha de la ventana encontraremos un botón de Ajustes. Al hacer clic sobre él nos aparecerá el siguiente diálogo:
![[PRO] Revisar Peraltes - MDT25 (3)](/media/61702429/image44.png)
General
Tema: Define el aspecto visual de la aplicación. Por defecto, viene establecido como BaseDark por lo que la aplicación tendrá fondos oscuros y textos claros. El valor alternativo sería BaseLight que invertirá dicho esquema de color: fondos claros y textos oscuros.
Color: Define la paleta de colores que emplea la aplicación. Por defecto, aparecerá en un color naranja (Orange). Se ofrece una variedad de colores posibles.
Idioma: Permite seleccionar el idioma de la aplicación
CAD
Cursor: Establece el color del cursor del visor CAD. Este cursor solo es visible cuando hay un comando de edición activo.
Puntos calientes: Establece el color de los puntos calientes de las entidades seleccionadas en el visor CAD.
Referencia de entidades: Establece el color de las marcas de referencia de entidades sobre el visor CAD cuando estemos en una operación que emplee dichas referencias.
Selección: Establece el color de los vértices seleccionados en una entidad del visor CAD.
Escala de las marcas: Establece la escala de tamaño para las marcas del visor CAD: puntos calientes y referencia de entidades.
Editor
Izquierda: Color por defecto para la capa donde se dibuja la polilínea que representa al peralte izquierdo.
Derecha: Color por defecto para la capa donde se dibuja la polilínea que representa al peralte derecho.
REF: Color por defecto para la capa donde se dibuja la línea de referencia, que indica donde está el 0% de peralte.
TXT: Color por defecto para la capa donde se dibujan los textos con los porcentajes de peralte de cada tamo.
Altura de texto: Establece el tamaño de los textos.
Barra de Herramientas
En la barra de herramientas encontramos los controles que nos permitirán gestionar el visor CAD así como la edición de los peraltes:
![[PRO] Revisar Peraltes - MDT25 (4)](/media/61702429/image45.webp)
Menú Archivo
Con los controles del menú archivo podemos crear peraltes desde cero, incorporar ficheros ya existentes o guardar las modificaciones de los peraltes en edición:
Nuevo: Crear un nuevo fichero de peraltes desde cero. Solicitará la ruta del nuevo fichero de peraltes y lo establecerá como activo.
Abrir: Solicita un fichero per o eje y lo incorpora al panel y al visor CAD.
Guardar: Si hay un fichero activo, por defecto solicitará la ubicación para almacenar un nuevo fichero per con los datos actuales del perfil: si se ha modificado se guardarán las modificaciones, en otro caso será una copia exacta del original. Si se modifica la extensión del fichero de salida, o no hay un fichero activo al momento de hacer clic en este icono, se nos presentarán las siguientes opciones:
Guardar como dxf: Guardará el dibujo actual del visor CAD en un fichero dxf. Esto incluye polilíneas que se hayan dibujado y las acotaciones realizadas.
Guardar como jpg: Nos permitirá guardar una captura de lo que está visible actualmente en el visor CAD con georreferencia. Para configurar la captura se nos mostrará el siguiente diálogo:
Captura de pantalla Georreferenciada
![[PRO] Revisar Peraltes - MDT25 (9)](/media/61702429/image50.webp)
Vista Actual
Área visible: Indica el tamaño de la pantalla en metros y pixeles.
Designar: Al hacer clic, entramos en un comando de zoom ventana con el que podemos establecer una región del dibujo en el visor para exportarla.
Configurar Imagen
Resolución: Nos permite establecer una resolución arbitraria, en pixeles, para la imagen capturada. Si la opción Mantener relación de aspecto está activada, la resolución siempre mantendrá la relación de aspecto actual del visor CAD. Variar la resolución afectara al tamaño de píxel.
Tamaño de píxel: Indica la escala de cada píxel en la imagen exportada. Por ejemplo, para una imagen que tiene un área visible de 100x100 metros y una resolución de 100x100 píxeles el tamaño de píxel será de 1x1 metros. Si la opción Mantener relación de aspecto está activada, el tamaño de píxel siempre será cuadrado lo que a su vez forzará que la resolución mantenga la relación de aspecto actual del visor CAD. Variar el tamaño de píxel afectará a la resolución.
Mantener relación de aspecto: Cuando está activada se fuerza que la resolución y el tamaño de píxel tengan la misma relación de aspecto que el visor CAD.
Generar Georreferencia: Si está activada, exporta un fichero de georreferencia jpw junto con la imagen jpg con lo que la imagen tendrá la información de tamaño de píxel y se podrá dibujar o medir sobre ella en cualquier software de CAD que permita trabajar con imágenes georreferenciadas. La imagen de salida siempre está ubicada con origen X=0,Y=0
Menú CAD
Con los controles del menú CAD podemos gestionar el visor CAD:
Rejilla: Permite activar/desactivar la rejilla del visor
Color de fondo del visor: Nos permite establecer el color de fondo del visor CAD
Control de capas: Nos permite gestionar las capas del visor CAD. Si hacemos clic en el icono se mostrará el siguiente diálogo:
![[PRO] Revisar Peraltes - MDT25 (14)](/media/61702429/image55.webp)
Cada capa tiene los siguientes controles:
Visibilidad: Establece si la capa está visible o no
Eliminar: Borra la capa del CAD. Esto no siempre es posible, hay capas especiales que no se pueden eliminar y cuyo ciclo de vida es gestionado por la aplicación.
Nombre de capa: Nos permite modificar el nombre de la capa. Hay capas especiales que no se pueden renombrar.
Grosor de línea/punto: Nos permite establecer el grosor de línea de la capa. Está limitado entre uno y diez.
Capa actual: Nos permite seleccionar la capa actual. Además, se pueden mostrar/ocultar capas directamente desde esté control haciendo clic en el icono de visibilidad
Grosor de línea global: Establece el grosor de línea de todas las capas de forma simultánea.
Factor vertical: Permite establecer un factor de escala vertical para exagerar las cotas en el visor CAD. Se permiten factores de: x1, x2, x3, x4, x5 y x10
Menú Referencia de Entidades
Con estos controles podemos gestionar la referencia de entidades del visor CAD:
De izquierda a derecha:
Referencia a punto: Si está activada se consideran entidades puntuales en la referencia de entidades. Útil para medir distancias entre puntos o para dibujar sobre puntos.
Referencia a punto final: Si está activada se consideran los vértices de las entidades en la referencia de entidades.
Referencia a punto medio: Si está activada considera los vértices centrales de los segmentos de entidades lineales en la referencia de entidades.
Referencia a punto cercano: Si está activada considera el vértice más cercano al cursor de dibujo, ya sea final, centro de un segmento o un vértice cualquiera de un segmento de una entidad lineal.
Activar/desactivar referencias: Establece si se debe considerar o no la referencia de entidades.
Menú Historia
Con los controles del menú historia podemos deshacer/rehacer los cambios realizados sobre los peraltes.:
De izquierda a derecha:
Deshacer: Deshace la última modificación del fichero activo.
Rehacer: Vuelve a aplicar la última modificación deshecha al fichero activo.
Estos controles solo se activarán cuando haya un fichero activo y este haya tenido alguna modificación.
Menú Edición
Con los controles de edición podemos iniciar diversos comandos de edición sobre entidades del visor CAD:
Insertar vértice: Comienza el comando de insertar vértice. Como primer paso debemos designar una entidad lineal a la que insertar el vértice Si designamos la polilínea del peralte izquierdo, estableceremos le porcentaje de peralte en el lado izquierdo. Si seleccionamos la derecha, lo estableceremos en el lado derecho. Se insertará el vértice en las coordenadas del cursor, estableciéndose los vértices anteriores y posteriores según la proyección en X del nuevo vértice (dado que en los peraltes el PK siempre es creciente y no puede haber dos definiciones de peraltes en un mismo PK)
Eliminar vértice: Comienza el comando de eliminar vértice. Como primer paso debemos designar una entidad lineal a la que eliminar vértices. Tras esto, veremos que se muestran sus vértices como puntos calientes y si hacemos clic en alguno de ellos se eliminará. Tanto si eliminamos el vértice de la polilínea de peralte izquierdo como del derecho, se eliminará de ambas polilíneas simultáneamente.
Eliminar rango de vértices: Comienza el comando de eliminar un rango de vértices. Como primer paso debemos designar una entidad lineal a la que eliminar vértices. Tras esto, veremos que se muestran sus vértices como puntos calientes. Habrá que marcar dos vértices, el inicial y el final, se eliminarán ambos y los vértices intermedios. Tanto si eliminamos los vértices de la polilínea de peralte izquierdo como del derecho, se eliminará de ambas polilíneas simultáneamente.
Eliminar vértices por ventana: Comienza el comando de eliminar vértices por ventana. Como primer paso debemos designar una entidad lineal a la que eliminar vértices. Tras esto, veremos que se muestran sus vértices como puntos calientes. Habrá que marcar las dos esquinas de la ventana, todos los vértices que queden contenidos en la misma se eliminarán de la entidad. Tanto si eliminamos los vértices de la polilínea de peralte izquierdo como del derecho, se eliminará de ambas polilíneas simultáneamente.
Menú Medición y Borrado
Con estos controles podemos establecer medidas en el dibujo, así como eliminarlas y borrar entidades del dibujo:
Medir: El comando medir nos pedirá designar dos puntos y nos dirá la distancia entre ellos. Se añadirá una línea con un texto con la medida al dibujo a una capa especial de medidas.
![[PRO] Revisar Peraltes - MDT25 (33)](/media/61702429/image73.webp)
Medir (XY): Es idéntico al comando de medir salvo que este al terminar inserta en el dibujo dos líneas adicionales con texto, mostrando la distancia en X e Y entre los dos puntos designados.
![[PRO] Revisar Peraltes - MDT25 (35)](/media/61702429/image75.webp)
Eliminar medidas: Borra del dibujo todas las mediciones.
Borrar entidades: Nos permite hacer una selección de entidades y eliminarlas del dibujo. Cuando entremos en este comando, al designar la entidad veremos que sus líneas se vuelven discontinuas, esto significa que está seleccionada para el borrado. Cuando estén seleccionadas todas las entidades pulsando intro, o usando la función análoga del menú de contexto, confirmamos el borrado. También se pueden borrar entidades seleccionándolas en el visor (haciendo clic sobre ellas) y pulsando la tecla suprimir. Hay entidades especiales que no se podrán eliminar, como las polilíneas que representan a los perfiles longitudinales.
Menú Zoom
Con estos controles podemos controlar el nivel de zoom del visor CAD:
Incrementar zoom: Aumenta el nivel de zoom actual
Reducir zoom: Reduce el nivel de zoom actual.
Zoom ventana: Se solicitará que se designen dos vértices para formar una ventana, la vista pasará a ser el contenido de dicha ventana haciendo el zoom necesario y centrando la vista en la misma.
Zoom extensión: Establece la vista de manera que todos los elementos que hay actualmente en el dibujo sean visibles.
Diagrama de Curvatura
Si incorporamos un fichero de eje (EJE) se nos mostrará una ventana flotante con el diagrama de curvatura del mismo.
![[PRO] Revisar Peraltes - MDT25 (43)](/media/61702429/image83.webp)
En la parte superior tenemos una barra de herramientas con controles idénticos a los de la barra de herramientas de la ventana principal. Salvo los dos controles que aparecen a la derecha del Menú CAD:
De izquierda a derecha:
Factor de curvatura: Factor a emplear en la representación del diagrama de curvatura al establecer la curvatura como: Radio / Factor de Curvatura
Altura de Texto: Tamaño de los textos mostrados sobre el diagrama de curvatura.
En el dibujo se muestra cada tramo del eje en un color distintivo: verde para rectas, rojo para clotoides y amarillo para curvas. Los textos que se muestran para cada tipo de alineación son:
Rectas: Recta y la longitud del tramo.
Curva: Radio y longitud del tramo
Clotoide: Parámetro (A) y longitud del tramo
En la parte inferior de la ventana, se muestra una barra de estado que nos indica las coordenadas (en términos de PK y Curvatura) del cursor y el fichero de eje que se está mostrando.
Panel de Peraltes
En la parte izquierda de la pantalla, se mostrarán los datos de los peraltes que están actualmente en edición. Adicionalmente, desde este mismo panel se proveerá de acceso a ciertas operaciones sobre los mismos.
![[PRO] Revisar Peraltes - MDT25 (45)](/media/61702429/image85.webp)
Insertar: Con este botón podemos agregar nuevas definiciones de peralte estableciendo PK, Izquierda y Derecha:
![[PRO] Revisar Peraltes - MDT25 (47)](/media/61702429/image87.png)
Listado de peraltes:
Para cada definición de peraltes, tendremos en el listado una línea como esta:
Los elementos, de izquierda a derecha son:
PK: El PK de los peraltes. Podemos hacer doble clic sobre el mismo y escribir el nuevo PK. El listado se reordenará por PK tras el cambio.
Izquierda: El porcentaje de peralte en el lado izquierdo. Podemos hacer doble clic sobre la misma y escribir el nuevo valor de peralte.
Derecha: El porcentaje de peralte en el lado derecho. Podemos hacer doble clic sobre la misma y escribir el nuevo valor de peralte.
Borrar: Elimina el peralte. También es posible eliminarlo si se selecciona la fila del listado y se pulsa la tecla suprimir.
Si se selecciona una fila del listado, el vértice correspondiente se resaltará en el visor CAD.
Herramientas de peraltes:
En la parte inferior derecha del panel podemos encontrar herramientas específicas de edición de los peraltes:
Invertir: Intercambia la definición de peraltes en el lado izquierdo y el derecho.
Desplazar PKs: Nos permite establecer un nuevo PK inicial para el perfil longitudinal, modificando en consecuencia los PK de todos los vértices.
![[PRO] Revisar Peraltes - MDT25 (53)](/media/61702429/image92.png)
Visor CAD
Desde el visor CAD podemos editar gráficamente los peraltes:
![[PRO] Revisar Peraltes - MDT25 (54)](/media/61702429/image93.webp)
Al hacer clic sobre una polilínea, esta pasará a selección. Al seleccionarse la entidad, veremos sus vértices como puntos calientes:
![[PRO] Revisar Peraltes - MDT25 (55)](/media/61702429/image94.webp)
Una vez en selección, si ponemos el cursor sobre uno de los vértices este se resaltará, tanto en el visor como en el Panel de Peraltes, y se mostrará el menú de contexto radial.
Menú de Contexto Radial
Cuando se resalta un vértice de una entidad seleccionada en el visor CAD, aparece este menú indicando las posibles operaciones sobre el vértice:
![[PRO] Revisar Peraltes - MDT25 (56)](/media/61702429/image95.webp)
Editar: Nos permite reubicar el vértice gráficamente con el cursor
Insertar: Inserta un nuevo vértice. La inserción se realiza de forma libre. Conforme movamos el cursor, veremos el resultado de confirmar la inserción en la ubicación del mismo. Al hacer clic se inserta el vértice. Podemos repetir la operación tantas veces como deseemos, el comando termina cuando se pulse "intro" o "escape", o las funciones análogas en el menú de contexto. Hay que tener en cuenta que, si el vértice es parte de la polilínea de peralte izquierdo, al insertar el vértice el peralte izquierdo estará definido según la posición del cursor pero el izquierdo estará a cero. Ídem para el lado derecho.
Borrar: Elimina el vértice. También es posible borrarlo, una vez que esté resaltado, pulsando la tecla suprimir.
Más opciones: Mostrará el menú de contexto mostrando todas las opciones de edición posibles sobre la entidad.
Menú de Contexto
En cualquier momento que hagamos clic derecho sobre el visor CAD, aparecerá el menú de contexto de la aplicación:
![[PRO] Revisar Peraltes - MDT25 (61)](/media/61702429/image100.png)
Las operaciones de edición solo aparecerán cuando hagamos clic derecho sobre una entidad. Dichas operaciones de edición son las mismas del Menú Edición de la barra de herramientas, si las usamos desde este menú evitamos tener que designar la entidad al comenzar el comando, puesto que ya se conoce la entidad sobre la que se desea actuar.
![[PRO] Revisar Peraltes - MDT25 (62)](/media/61702429/image101.png)
De la misma manera, en los submenús de Referencia de Entidades y Zoom encontramos los comandos de los menús de mismo nombre de la barra de herramientas:
![[PRO] Revisar Peraltes - MDT25 (63)](/media/61702429/image102.png)
![[PRO] Revisar Peraltes - MDT25 (64)](/media/61702429/image103.png)
Si la aplicación se encuentra en un comando y se abre el menú contextual, haciendo clic derecho en el visor CAD, se nos darán opciones adicionales para terminar el comando, mediante un intro o un escape:
![[PRO] Revisar Peraltes - MDT25 (65)](/media/61702429/image104.png)