tcpMDT
[PRO] Reverse Vertical Alignment - MDT26
Reverse Vertical Alignment
Command to execute in the CAD | |
|---|---|
Vertical menu | MDT26 > Vertical Alignments > Modify > Reverse Vertical Alignment |
Ribbon menu | V.Alignments > Edit > Invert |
Command line |
This command is used to invert a vertical alignment file. The process is performed by inverting the vertex stations, maintaining the same distance between them and leaving the transition's curves values unchanged. An example of running this command is shown below.
Original vertical alignment:
0.000 540.062 0.000 0.000 0.000
177.763 563.330 55.000 7.901 0.567
302.571 543.810 300.000 40.962 2.796
870.839 610.115 0.000 0.000 0.000
Inverted vertical alignment:
0.000 610.115 0.000 0.000 0.000
568.268 543.810 300.000 40.962 2.796
693.076 563.330 55.000 7.901 0.567
870.839 540.062 0.000 0.000 0.000
Review Vertical Alignment ![[PRO] Reverse Vertical Alignment - MDT26 (3)](/media/214041123/image175.png)
This application allow us to edit and visualize a vertical alignment (ras file) and to also visualize the terrain's long section (lon file) as reference.
Once we run the application, we'll see something similar to this:
Along this document we are going to detail each of the parts, as a general overview we can distinguish multiple sections in the application's interface:
Title bar: At the top, the orange bar. The application's title appears at the left side. To the right we can find some options: Settings, Help and About us. Further to the right we have the usual window's controls: minimize, maximize/restore and close.
Toolbar: Just under the title bar. It allow us to manage the state of the view and to access to all the different edition tools.
CAD View: The application provides a CAD view in which the vertical alignment will be represented as polylines, it also allow us to take measures.
Vertical Alignment's Panel: Under the CAD view we can see a panel with the active vertical alignment's information.
Status bar: At the window's bottom, the orange bar. It provide us with general information as: the cursor coordinates in the drawing, the vertical alignment's elevation and (if there's a longitudinal loaded) the terrain's height and height difference. It'll also show information messages during the edition commands
Settings
At the window's top right corner, we'll find a Settings button. When it's clicked the following dialog will show:
![[PRO] Reverse Vertical Alignment - MDT26 (5)](/media/214041123/image604.png)
General
Theme: Defines the application's visuals. By default, it's settled as BaseDark so the application should have dark background and light foreground. The alternative would be the BaseLight theme which inverts the previous color scheme: light background and dark foreground.
Color: Defines the color palette used by the application. By default, it's settled to Orange. It can be stablished from a variety of colors.
Language: Allow us to choose the application's language
CAD
Cursor: Sets the color of the CAD view's cursor. This cursor it's only visible when there's an edition command active.
Hotspots: Sets the hotspots color for the selected entities in the CAD view.
Entity Reference: Sets the color for the entity reference marks in the CAD view when it's doing an operation which uses those references.
Selection: Sets the color for the selected vertices in a CAD view's entity.
Marks Scale: Sets the size scale for the CAD view's marks: hotspots and entity references.
Editor
Default layer colors: Allow us to set the colors for the CAD view's layers.
PRV: Previous vertical alignment's color, dark green by default.
DEF: Definitive vertical alignment's color, red by default.
TXT: Texts color, violet by default.
LON: Profile's color, light green by default.
Toolbar
In the toolbar we find all the controls that allow us to manage the CAD view and the alignment edition:
![[PRO] Reverse Vertical Alignment - MDT26 (6)](/media/214041123/image605.webp)
File Menu
With these controls we can create a new vertical alignment, add an existing file or save the changes of the alignment in edition:
New: Creates a new vertical alignment. It will ask for a file path for the new vertical alignment and it will set the new blank file as the active one.
Open: Asks for a ras, lon or LandXML file and adds it to the panel and the CAD view. In case of importing a vertical alignment from a LandXML file that has more than one vertical alignment, the following dialog will be shown so that we can choose the desired alignment:
![[PRO] Reverse Vertical Alignment - MDT26 (10)](/media/214041123/image606.png)
Once we click ok, the application will ask for a path for the imported ras file and it will be stablished as the active one.
Save: If there's an alignment active, by default it will ask for a path to store a new ras or LandXML file with the current alignment's data: if it has been modified the changes will be stored, otherwise it will be an exact copy from the original. If the output's file extension is changed, or there's no active alignment when the button is clicked, the following options will be presented:
Save as dxf: Saves the current drawing in the CAD view in a dxf file. This includes polylines and measures drawn by the user.
Save as jpg: Allow us to store a georeferenced screenshot of what is currently visible in the CAD view. To adjust the screenshot settings the following dialog will be shown:
Georeferenced Screenshot
![[PRO] Reverse Vertical Alignment - MDT26 (12)](/media/214041123/image341.png)
Current View
Visible area: Shows the screen size in meters and pixels.
Set: On click, we enter in a zoom by window command that we can use to set a region in the drawing.
Image Configuration
Resolution: Allow us to set a custom resolution, in pixels, for the screenshot. If the option Keep Aspect Ratio is on, the resolution will maintain the current CAD view's aspect ratio. Varying the resolution will affect the pixel size.
Pixel size: Shows the scale of each pixel in the generated image. For example, for an image which has a visible area of 100x100 meters and a resolution of 100x100 pixels, the pixel size will be 1x1 meters. If the option Keep Aspect Ratio is on, the resolution will maintain the current CAD view's aspect ratio. Varying the pixel size will affect the resolution.
Keep aspect ratio: When it's active the pixel size and resolution are forced to have the same aspect ratio than the CAD view.
Generate Georeference: When active, exports a jpw georefence file along with the jpg image so the screenshot will have the pixel size information and could be drawn or measured on any CAD software that supports georeferenced images. The output image will always be located at the origin X=0,Y=0
CAD Menu
With the CAD menu controls we can manage the CAD view:
Grid: Enable/Disable the grid
Background color: Sets the CAD view's background color.
Layer configuration: Allow us to manage the CAD view's layers. When we click the icon, the following dialog is shown:
![[PRO] Reverse Vertical Alignment - MDT26 (17)](/media/214041123/image359.webp)
Each layer has the following controls:
Visibility: Sets if the layer is visible or not.
Remove: Deletes the layer from the CAD. This is not always possible, there are special layers which can't be removed and whose life cycle is managed by the application.
Layer's name: Allow us to modify the layer's name. There's special layers that can't be renamed.
Line/Point width: Allow us to set the line/point width for the layer. Is bounded between one and ten.
Current Layer: Allow us to select the current layer. Also, layers can be shown or hidden by clicking the visibility icon ![[PRO] Reverse Vertical Alignment - MDT26 (24)](/media/214041123/image361.webp)
Global line width: Sets the line width for each layer simultaneously.
Vertical factor: Sets a vertical scale factor to apply to the elevations in the CAD view. Allowed factors are: x1, x2, x3, x4, x5 and x10
Entity Reference Menu
With these controls we can manage the CAD view's entity references:
From left to right:
Point reference: When enabled, points are considered in entity referencing. Useful to measure distances between points or drawing on points.
Final Point reference: When enabled, entities vertices are considered in entity referencing.
Middle point reference: When enabled, middle points of linear entities segments are considered in entity referencing.
Near Point reference: When enabled, the nearest vertex to the drawing cursor is considered in entity referencing. Vertex could be final point, middle point or any vertex in a linear entity segment.
Enable/disable references: Sets if entity referencing should be performed or not.
History Menu
With the history menu controls we can undo/redo the changes performed in the alignment:
From left to right:
Undo: Undoes the last change in the active alignment.
Redo: Redoes the last undone change in the active alignment.
These controls will be active only when there's an active alignment with any changes.
Edition Menu
With the edition controls we can perform diverse edition commands on CAD view's entities
Add vertex: Runs the add vertex command. As first step we must select a linear entity to add the vertex to. In order to edit the vertical alignment, the previous vertical alignment's polyline must be selected. The vertex will be added at the cursor's coordinates, setting the previous and next vertices according to the X projection of the new vertex (given that in a vertical alignment the Station is always growing and can't have two elevations at the same Station)
Remove vertex: Runs the remove vertex command. As first step we must select a linear entity. In order to edit the vertical alignment, the previous vertical alignment's polyline must be selected. After that, the entity's vertices will be shown as hotspots and, if we click one of them, the vertex will be removed.
Remove vertices range: Runs the remove vertices range command. As first step we must select a linear entity. In order to edit the vertical alignment, the previous vertical alignment's polyline must be selected. After that, the entity's vertices will be shown as hotspots. We have to click two vertices, the first and last, both will be removed along with all the vertices between them.
Remove vertices in window: Runs the remove vertices in window command. As first step we must select a linear entity. After that, the entity's vertices will be shown as hotspots. After that, the entity's vertices will be shown as hotspots. We have to set the two corners of the window, all the vertices contained within the window will be removed.
Vertical Alignment's Menu
These controls manage aspects that are exclusive of the vertical alignment:
From left to right:
Cursor constraints: When a previous vertical alignment is modified graphically, it's possible to restrict the cursor movement in order to have a better control over the edition. The possible restriction modes are:
Free: There's no restrictions
Fix Elevation: Cursor can only move horizontally
Fix Station: Cursor can only move vertically.
Fix to Previous Tangent: Cursor can only move along the direction defined by the tangent from the previous vertex to the current one.
Fix to Next Tangent: Cursor can only move along the direction defined by the tangent from the current vertex to the next one.
Set Waypoint: Allow us to set a point graphically so that the alignment readjusts itself to make the definitive vertical alignment pass by those coordinates. This isn't always possible, in case of overlap, the alignment won't be modified, and an error message will appear.
Measuring and Removal Menu
With these controls we can add measures to the drawing, remove them and remove entities from the drawing:
Measure: The measure command will ask for two points and it will tell the distance between them. A new line will be added to the drawing, along with a text with the line's length, to a special measures layer.
![[PRO] Reverse Vertical Alignment - MDT26 (37)](/media/214041123/image350.webp)
Measure (XY): It's the same as the measure command except that once the command finishes two additional lines with text will be added showing the distance in the X and Y axis between the two selected points.
![[PRO] Reverse Vertical Alignment - MDT26 (39)](/media/214041123/image352.webp)
Remove measures: Removes all the measures from the drawing.
Erase entities: It allow us to select entities and remove them from the drawing. Once we run this command, when an entity is selected, we'll see that it's lines will become dotted, that means that it's selected for removal. Once all the desired entities are selected, by pressing Enter, or using the analogous function in the context menu, the removal is confirmed. Entities can also be removed by selecting them in the CAD view (clicking on them) and pressing the delete key. There are special entities that can't be removed.
Zoom Menu
With these controls we control the CAD view zoom level:
Zoom in: Increases the current zoom level.
Zoom out: Reduces the current zoom level.
Zoom extents: Fit all the drawing entities on the screen.
Vertical Alignment's Panel
Under the CAD view we'll see a panel with the current alignment's information.
![[PRO] Reverse Vertical Alignment - MDT26 (46)](/media/214041123/image609.webp)
Add: It will show the Edit Vertical Alignment's Node dialog so that we can set the new node's Station and Height. At all times we'll see, as a yellow dotted line, how the modifications will affect the definitive vertical alignment. If the insertion provokes an overlap, the application will warn us and won't let us accept the dialog.
Node list:
For each alignment's node, the following information is shown in the list. From left to right:
Station: The node's Station. It can be edited by double clicking it, it can only be confirmed if the new station doesn't provoke an overlap.
Height: The node's Height. It can be edited by double clicking it, it can only be confirmed if the new height doesn't provoke an overlap.
Kv: Node's vertical curve. It can be edited by double clicking it, it can only be confirmed if the new Kv doesn't provoke an overlap.
Tangent: Node's tangent's length. It can be edited by double clicking it, it can only be confirmed if the new tangent doesn't provoke an overlap.
Arrow: Node's arrow's length. It can be edited by double clicking it, it can only be confirmed if the new arrow doesn't provoke an overlap.
Slope: The node's slope value. It's the slope between that node and the next one. The slope direction is defined by the value's sign. Positive slopes are displayed with a green text, negative ones with a red text.
Remove: Removes the vertical alignment's node.
Vertical alignment's tools:
At the panel's bottom right, we can find specific vertical alignment edition tools:
![[PRO] Reverse Vertical Alignment - MDT26 (49)](/media/214041123/image372.webp)
Offset Stations: Allow us to set a new initial station for the alignment, modifying the stations of each node.
![[PRO] Reverse Vertical Alignment - MDT26 (51)](/media/214041123/image373.png)
Offset heights: Allow us to set an elevation offset that will be applied to each all the alignment's nodes.
![[PRO] Reverse Vertical Alignment - MDT26 (53)](/media/214041123/image480.png)
Invert: Inverts the alignment's direction.
Edit Vertical Alignment's Node
This dialog will be shown when we add a new node or in some edition operations as: editing the node's vertical curve from the Radial Context Menu
![[PRO] Reverse Vertical Alignment - MDT26 (55)](/media/214041123/image611.png)
Station: It allow us to set the node's station. In case of inserting the node graphically or be using the edit vertical curve command, the control will be locked.
Elevation: It allow us to set the node's height. In case of inserting the node graphically or be using the edit vertical curve command, the control will be locked.
Kv: It allow us to set the node's vertical curve. In case of adding the node from the Vertical Alignment's Panel, it will be locked.
Tangent: Allow us to set the node's tangent. In case of adding the node from the Vertical Alignment's Panel, it will be locked.
Arrow: Allow us to set the node's arrow. In case of adding the node from the Vertical Alignment's Panel, it will be locked.
At all times we will see, as a yellow dotted line, the result of applying the changes to the alignment. If the parameters settled provokes an overlap, the dialog will show a warn message and the ok button will be locked.
CAD View
On the CAD view we can graphically edit the alignment:
![[PRO] Reverse Vertical Alignment - MDT26 (56)](/media/214041123/image612.webp)
By clicking on the previous vertical alignment, it will be selected. Once is selected, we'll see its vertices as hotspots:
![[PRO] Reverse Vertical Alignment - MDT26 (57)](/media/214041123/image613.webp)
If we move the cursor over one of the vertices, it will be highlighted (on the CAD view and on the Vertical Alignment's Panel) and the radial context menu will appear.
Radial Context Menu
When a vertex from a CAD view selected entity is highlighted, this menu will be shown with the possible operations on this vertex:
![[PRO] Reverse Vertical Alignment - MDT26 (58)](/media/214041123/image614.webp)
Edit: It allow us to move the vertex graphically with the cursor. In case of having cursor, constraints enabled, the vertex's movement will be limited to the restriction's direction.
Edit vertical curve: Shows the Edit Vertical Alignment's Node dialog which we can set the node's Kv, tangent and arrow.
Add: Adds a new node. In case of vertical alignments, the insertion has no restrictions. As we move the cursor, we'll see the result of inserting a new vertex at that location. Once we click, the vertex will be added if it's not provoking an overlap and the Edit Vertical Alignment's dialog will show so that we can define the vertical curve parameters. We can repeat this process as many times as we want, the command will finish when the Enter or Escape keys, or the analogous context menu functions, are pressed.
Remove: Removes the vertex. It's also possible to remove it, once it's highlighted, by pressing the delete key.
More options: It will show the context menu with all of the entity's possible edition options.
Context Menu
Any time that we right click on the CAD view, the application's context menu will be shown:
![[PRO] Reverse Vertical Alignment - MDT26 (64)](/media/214041123/image616.png)
The cursor constraints submenu and the Set Waypoint tool are the same than the ones in the Vertical Alignment's Menu on the toolbar.
The edition submenu will appear only when there's an active alignment. Those edition operations are the same than the ones in the Edition Menu on the toolbar.
![[PRO] Reverse Vertical Alignment - MDT26 (65)](/media/214041123/image617.png)
In a similar manner, in the Entity Reference and Zoom submenus we'll find the commands from the menus with the same name from the toolbar:
![[PRO] Reverse Vertical Alignment - MDT26 (66)](/media/214041123/image384.png)
![[PRO] Reverse Vertical Alignment - MDT26 (67)](/media/214041123/image385.png)
If the application it's in an interactive command and the context menu is opened, by right clicking on the CAD view, additional options will be shown for finishing the command, by Enter or Escape.
![[PRO] Reverse Vertical Alignment - MDT26 (68)](/media/214041123/image386.png)